CVE-2020-5259

Prototype Pollution in Dojox

HIGH
8.6
CVSS Score
Published: March 10, 2020 at 05:50 PM UTC
Updated: June 17, 2026 at 03:21 AM UTC
2 products affected across 2 vendorsDojoxDojox

Using dojox by dojo?

Get instant alerts when new vulnerabilities affect dojox - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.6
Exploit prediction
EPSS 2%

Description

In affected versions of dojox (NPM package), the jqMix method is vulnerable to Prototype Pollution. Prototype Pollution refers to the ability to inject properties into existing JavaScript language construct prototypes, such as objects. An attacker manipulates these attributes to overwrite, or pollute, a JavaScript application object prototype of the base object by injecting other values. This has been patched in versions 1.11.10, 1.12.8, 1.13.7, 1.14.6, 1.15.3 and 1.16.2

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.11.101.12.0 ≤ v < 1.12.81.13.0 ≤ v < 1.13.71.14.0 ≤ v < 1.14.61.15.0 ≤ v < 1.15.31.16.0 ≤ v < 1.16.2
Affected range stops below 1.11.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.12.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.13.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.14.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.15.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.16.2, so it looks safe — our inference, not a vendor statement
v < 1.11.10v < 1.12.8v < 1.13.7v < 1.14.6v < 1.15.3v < 1.16.2
Affected range stops below 1.11.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.12.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.13.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.14.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.15.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.16.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
CHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-94CWE-74

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card