CVE-2020-5210

NetHack command line -w option parsing is subject to a buffer overflow

HIGH
7.8
CVSS Score
Published: January 28, 2020 at 05:50 PM UTC
Updated: June 17, 2026 at 03:21 AM UTC
1 product affected across 1 vendorNetHack

Using NetHack by NetHack?

Get instant alerts when new vulnerabilities affect NetHack - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.8%

Description

In NetHack before 3.6.5, an invalid argument to the -w command line option can cause a buffer overflow resulting in a crash or remote code execution/privilege escalation. This vulnerability affects systems that have NetHack installed suid/sgid and shared systems that allow users to influence command line options. Users should upgrade to NetHack 3.6.5.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.6.5
Affected range stops below 3.6.5, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-120

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card