CVE-2020-4050

set-screen-option filter misuse by plugins leading to privilege escalation in WordPress

LOW
3.1
CVSS Score
Published: June 12, 2020 at 04:00 PM UTC
Updated: June 17, 2026 at 03:19 AM UTC
3 products affected across 3 vendorsDebian LinuxFedoraWordPress

Using wordpress-develop by WordPress?

Get instant alerts when new vulnerabilities affect wordpress-develop - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.1
Exploit prediction
EPSS 1%

Description

In affected versions of WordPress, misuse of the `set-screen-option` filter's return value allows arbitrary user meta fields to be saved. It does require an admin to install a plugin that would misuse the filter. Once installed, it can be leveraged by low privileged users. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.7.34v < 3.8.34v < 3.9.32v < 4.0.31v < 4.1.31v < 4.2.28v < 4.3.24v < 4.4.23v < 4.5.22v < 4.6.19v < 4.7.18v < 4.8.14v < 4.9.15v < 5.0.10v < 5.1.6v < 5.2.7v < 5.3.4v < 5.4.23.7 ≤ v < 3.7.343.8 ≤ v < 3.8.343.9 ≤ v < 3.9.324.0 ≤ v < 4.0.314.1 ≤ v < 4.1.314.2 ≤ v < 4.2.284.3 ≤ v < 4.3.244.4 ≤ v < 4.4.234.5 ≤ v < 4.5.224.6 ≤ v < 4.6.194.7 ≤ v < 4.7.184.8 ≤ v < 4.8.144.9 ≤ v < 4.9.155.0 ≤ v < 5.0.105.1 ≤ v < 5.1.65.2 ≤ v < 5.2.75.3.0 ≤ v < 5.3.45.4 ≤ v < 5.4.2
Affected range stops below 3.7.34, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.8.34, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.9.32, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.31, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.31, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.28, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.24, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.19, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.1.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.2, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-288

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card