CVE-2020-36636

OpenMRS Admin UI Module Account Setup AccountPageController.java sendErrorMessage cross site scripting

MEDIUM
6.1
CVSS Score
Published: December 27, 2022 at 10:59 PM UTC
Updated: June 17, 2026 at 03:15 AM UTC
1 product affected across 1 vendorAdmin UI Module

Using Admin UI Module by OpenMRS?

Get instant alerts when new vulnerabilities affect Admin UI Module - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 1.0%

Description

A vulnerability classified as problematic has been found in OpenMRS Admin UI Module up to 1.4.x. Affected is the function sendErrorMessage of the file omod/src/main/java/org/openmrs/module/adminui/page/controller/systemadmin/accounts/AccountPageController.java of the component Account Setup Handler. The manipulation leads to cross site scripting. It is possible to launch the attack remotely. Upgrading to version 1.5.0 is able to address this issue. The name of the patch is 702fbfdac7c4418f23bb5f6452482b4a88020061. It is recommended to upgrade the affected component. VDB-216918 is the identifier assigned to this vulnerability.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Affected range stops below 1.5.0, so it looks safe — our inference, not a vendor statement

References (5)

SignaturePermissions RequiredThird Party Advisory
https://vuldb.com/?ctiid.216918
VDB EntryTechnical DescriptionPermissions RequiredThird Party Advisory
https://vuldb.com/?id.216918

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card