CVE-2020-26271

Heap out of bounds access in MakeEdge in TensorFlow

LOW
3.3
CVSS Score
Published: December 10, 2020 at 10:10 PM UTC
Updated: June 17, 2026 at 03:07 AM UTC
2 products affected across 2 vendorsTensorflowTensorFlow

Using tensorflow by tensorflow?

Get instant alerts when new vulnerabilities affect tensorflow - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW3.3
Exploit prediction
EPSS 0.2%

Description

In affected versions of TensorFlow under certain cases, loading a saved model can result in accessing uninitialized memory while building the computation graph. The MakeEdge function creates an edge between one output tensor of the src node (given by output_index) and the input slot of the dst node (given by input_index). This is only possible if the types of the tensors on both sides coincide, so the function begins by obtaining the corresponding DataType values and comparing these for equality. However, there is no check that the indices point to inside of the arrays they index into. Thus, this can result in accessing data out of bounds of the corresponding heap allocated arrays. In most scenarios, this can manifest as unitialized data access, but if the index points far away from the boundaries of the arrays this can be used to leak addresses from the library. This is fixed in versions 1.15.5, 2.0.4, 2.1.3, 2.2.2, 2.3.2, and 2.4.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.15.52.0.0 ≤ v < 2.0.42.1.0 ≤ v < 2.1.32.2.0 ≤ v < 2.2.22.3.0 ≤ v < 2.3.2
Affected range stops below 1.15.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.3.2, so it looks safe — our inference, not a vendor statement
v < 1.15.5v < 2.0.4v < 2.1.3v < 2.2.2v < 2.3.2
Affected range stops below 1.15.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.3.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-125

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card