CVE-2020-26216

Cross-Site Scripting in TYPO3 Fluid

MEDIUM
6.1
CVSS Score
Published: November 17, 2020 at 08:45 PM UTC
Updated: June 17, 2026 at 03:07 AM UTC
1 product affected across 1 vendorFluid

Using Fluid by TYPO3?

Get instant alerts when new vulnerabilities affect Fluid - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 1%

Description

TYPO3 Fluid before versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 and 2.6.10 is vulnerable to Cross-Site Scripting. Three XSS vulnerabilities have been detected in Fluid: 1. TagBasedViewHelper allowed XSS through maliciously crafted additionalAttributes arrays by creating keys with attribute-closing quotes followed by HTML. When rendering such attributes, TagBuilder would not escape the keys. 2. ViewHelpers which used the CompileWithContentArgumentAndRenderStatic trait, and which declared escapeOutput = false, would receive the content argument in unescaped format. 3. Subclasses of AbstractConditionViewHelper would receive the then and else arguments in unescaped format. Update to versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 or 2.6.10 of this typo3fluid/fluid package that fix the problem described. More details are available in the linked advisory.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.0.8v < 2.1.7v < 2.2.4v < 2.3.7v < 2.4.4v < 2.5.11v < 2.6.102.1.0 ≤ v < 2.1.72.2.0 ≤ v < 2.2.42.3.0 ≤ v < 2.3.72.4.0 ≤ v < 2.4.42.5.0 ≤ v < 2.5.112.6.0 ≤ v < 2.6.10
Affected range stops below 2.0.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.3.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.4.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.5.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.6.10, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card