CVE-2020-2307

MEDIUM
4.3
CVSS Score
Published: November 4, 2020 at 02:35 PM UTC
Updated: June 17, 2026 at 03:12 AM UTC
1 product affected across 1 vendorKubernetes

Using Jenkins Kubernetes Plugin by Jenkins project?

Get instant alerts when new vulnerabilities affect Jenkins Kubernetes Plugin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 1%

Description

Jenkins Kubernetes Plugin 1.27.3 and earlier allows low-privilege users to access possibly sensitive Jenkins controller environment variables.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Kubernetes· Jenkinsjenkins-plugin
95%
v ≤ 1.27.3
Vendor states this is fixed in 1.21.6 (unaffected)
Vendor states this is fixed in 1.25.4.1 (unaffected)
Vendor states this is fixed in 1.26.5 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card