CVE-2020-2038

PAN-OS: OS command injection vulnerability in the management web interface

HIGH
7.2
CVSS Score
Published: September 9, 2020 at 04:45 PM UTC
Updated: June 17, 2026 at 03:11 AM UTC
1 product affected across 1 vendorPAN-OS

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 86%

Description

An OS Command Injection vulnerability in the PAN-OS management interface that allows authenticated administrators to execute arbitrary OS commands with root privileges. This issue impacts: PAN-OS 9.0 versions earlier than 9.0.10; PAN-OS 9.1 versions earlier than 9.1.4; PAN-OS 10.0 versions earlier than 10.0.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

10.0 ≤ v < 10.0.110.0.0 ≤ v < 10.0.19.0 ≤ v < 9.0.109.0.0 ≤ v < 9.0.109.1 ≤ v < 9.1.49.1.0 ≤ v < 9.1.410.09.09.1
Affected range stops below 10.0.1, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 8.1.* (unaffected)
Affected range stops below 9.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

7.2HIGHpalo_alto
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card