CVE-2020-2010

PAN-OS: Authenticated user command injection vulnerability

HIGH
7.2
CVSS Score
Published: May 13, 2020 at 07:07 PM UTC
Updated: June 17, 2026 at 03:11 AM UTC
1 product affected across 1 vendorPAN-OS

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 2%

Description

An OS command injection vulnerability in PAN-OS management interface allows an authenticated administrator to execute arbitrary OS commands with root privileges. This issue affects: All versions of PAN-OS 7.1 and 8.0; PAN-OS 8.1 versions earlier than 8.1.14; PAN-OS 9.0 versions earlier than 9.0.7.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

7.1.0 ≤ v ≤ 7.1.268.0.0 ≤ v ≤ 8.0.208.1 ≤ v < 8.1.148.1.0 ≤ v ≤ 8.1.139.0 ≤ v < 9.0.79.0.0 ≤ v ≤ 9.0.67.1.*8.0.*8.19.0
Affected range stops below 8.1.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.7, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 9.1.0 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

7.2HIGHpalo_alto
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card