CVE-2020-1990

PAN-OS: Buffer overflow in the management server

HIGH
7.2
CVSS Score
Published: April 8, 2020 at 06:41 PM UTC
Updated: June 17, 2026 at 03:02 AM UTC
1 product affected across 1 vendorPAN-OS

Using PAN-OS by Palo Alto Networks?

Get instant alerts when new vulnerabilities affect PAN-OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 2%

Description

A stack-based buffer overflow vulnerability in the management server component of PAN-OS allows an authenticated user to upload a corrupted PAN-OS configuration and potentially execute code with root privileges. This issue affects Palo Alto Networks PAN-OS 8.1 versions before 8.1.13; 9.0 versions before 9.0.7. This issue does not affect PAN-OS 7.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

8.1 ≤ v < 8.1.138.1.0 ≤ v < 8.1.139.0 ≤ v < 9.0.79.0.0 ≤ v < 9.0.78.19.0
Vendor states this is fixed in 7.1.* (unaffected)
Affected range stops below 8.1.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.0.7, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

7.2HIGHpalo_alto
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-121CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card