CVE-2020-1762

HIGH
8.6
CVSS Score
Published: April 27, 2020 at 08:41 PM UTC
Updated: June 17, 2026 at 03:02 AM UTC
2 products affected across 2 vendorsOpenShift Service Mesh[Kiali]

Using kiali by [Kiali]?

Get instant alerts when new vulnerabilities affect kiali - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.6
Exploit prediction
EPSS 1%

Description

An insufficient JWT validation vulnerability was found in Kiali versions 0.4.0 to 1.15.0 and was fixed in Kiali version 1.15.1, wherein a remote attacker could abuse this flaw by stealing a valid JWT cookie and using that to spoof a user session, possibly gaining privileges to view and alter the Istio configuration.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.15.10.4.0 ≤ v < 1.15.1
Affected range stops below 1.15.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

x_refsource_CONFIRMIssue TrackingThird Party Advisory
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2020-1762

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-384CWE-613

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card