CVE-2020-1737

HIGH
7.8
CVSS Score
Published: March 9, 2020 at 03:11 PM UTC
Updated: June 17, 2026 at 03:02 AM UTC
3 products affected across 1 vendorAnsible TowerAnsible EngineAnsible

Using Ansible by Red Hat?

Get instant alerts when new vulnerabilities affect Ansible - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.8
Exploit prediction
EPSS 0.4%

Description

A flaw was found in Ansible 2.7.17 and prior, 2.8.9 and prior, and 2.9.6 and prior when using the Extract-Zip function from the win_unzip module as the extracted file(s) are not checked if they belong to the destination folder. An attacker could take advantage of this flaw by crafting an archive anywhere in the file system, using a path traversal. This issue is fixed in 2.10.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.7.172.8.0 ≤ v < 2.8.92.9.0 ≤ v < 2.9.6
Affected range stops below 2.7.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.8.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.9.6, so it looks safe — our inference, not a vendor statement
v ≤ 3.3.43.4.0 ≤ v ≤ 3.4.53.5.0 ≤ v ≤ 3.5.53.6.0 ≤ v ≤ 3.6.3
v ≤ 2.7.17v ≤ 2.8.9v ≤ 2.9.6
Vendor states this is fixed in 2.10 (unaffected)

CVSS

Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card