CVE-2020-1673

Junos OS: Reflected Cross-site Scripting vulnerability in J-Web and web based (HTTP/HTTPS) services

HIGH
8.8
CVSS Score
Published: October 16, 2020 at 08:31 PM UTC
Updated: June 17, 2026 at 03:02 AM UTC
1 product affected across 1 vendorJunos

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 2%

Description

Insufficient Cross-Site Scripting (XSS) protection in Juniper Networks J-Web and web based (HTTP/HTTPS) services allows an unauthenticated attacker to hijack the target user's HTTP/HTTPS session and perform administrative actions on the Junos device as the targeted user. This issue only affects Juniper Networks Junos OS devices with HTTP/HTTPS services enabled such as J-Web, Web Authentication, Dynamic-VPN (DVPN), Firewall Authentication Pass-Through with Web-Redirect, and Zero Touch Provisioning (ZTP). Junos OS devices with HTTP/HTTPS services disabled are not affected. If HTTP/HTTPS services are enabled, the following command will show the httpd processes: user@device> show system processes | match http 5260 - S 0:00.13 /usr/sbin/httpd-gk -N 5797 - I 0:00.10 /usr/sbin/httpd --config /jail/var/etc/httpd.conf In order to successfully exploit this vulnerability, the attacker needs to convince the device administrator to take action such as clicking the crafted URL sent via phishing email or convince the administrator to input data in the browser console. This issue affects Juniper Networks Junos OS: 18.1 versions prior to 18.1R3-S1; 18.2 versions prior to 18.2R3-S5; 18.3 versions prior to 18.3R2-S4, 18.3R3-S2; 18.4 versions prior to 18.4R2-S5, 18.4R3-S2; 19.1 versions prior to 19.1R2-S2, 19.1R3-S1; 19.2 versions prior to 19.2R1-S5, 19.2R2; 19.3 versions prior to 19.3R2-S4, 19.3R3; 19.4 versions prior to 19.4R1-S3, 19.4R2; 20.1 versions prior to 20.1R1-S2, 20.1R2. This issue does not affect Juniper Networks Junos OS prior to 18.1R1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 18.1R1 (unaffected)
Affected range stops below 18.1R3-S11, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.2R3-S5, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.3R2-S4, 18.3R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.4R2-S5, 18.4R3-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.1R2-S2, 19.1R3-S1, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.2R1-S5, 19.2R2, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.3R2-S4, 19.3R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 19.4R1-S3, 19.4R2, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.1R1-S2, 20.1R2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_CONFIRMVendor Advisory
https://kb.juniper.net/JSA11070

CVSS

8.8HIGHjuniper
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card