CVE-2020-16123

Bypass of snapd pulseaudio restrictions

MEDIUM
4.7
CVSS Score
Published: December 3, 2020 at 11:15 PM UTC
Updated: June 17, 2026 at 02:57 AM UTC
2 products affected across 2 vendorsUbuntu LinuxPulseaudio

Using pulseaudio by Canonical?

Get instant alerts when new vulnerabilities affect pulseaudio - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.7
Exploit prediction
EPSS 0.3%

Description

An Ubuntu-specific patch in PulseAudio created a race condition where the snap policy module would fail to identify a client connection from a snap as coming from a snap if SCM_CREDENTIALS were missing, allowing the snap to connect to PulseAudio without proper confinement. This could be exploited by an attacker to expose sensitive information. Fixed in 1:13.99.3-1ubuntu2, 1:13.99.2-1ubuntu2.1, 1:13.99.1-1ubuntu3.8, 1:11.1-1ubuntu7.11, and 1:8.0-0ubuntu3.15.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

1:11.1-1 ≤ v < 1:11.1-1ubuntu7.111:13.99.1-1 ≤ v < 1:13.99.1-1ubuntu3.81:13.99.2-1 ≤ v < 1:13.99.2-1ubuntu2.11:13.99.3-1 ≤ v < 1:13.99.3-1ubuntu21:8.0-0 ≤ v < 1:8.0-0ubuntu3.151:11.1-11:13.99.1-11:13.99.2-11:13.99.3-11:8.0-0
Affected range stops below 1:11.1-1ubuntu7.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 1:13.99.1-1ubuntu3.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 1:13.99.2-1ubuntu2.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1:13.99.3-1ubuntu2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1:8.0-0ubuntu3.15, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

Vendor Advisoryx_refsource_UBUNTUExploitIssue TrackingThird Party Advisory
https://launchpad.net/bugs/1895928
Vendor Advisoryx_refsource_UBUNTUPatchThird Party Advisory
https://ubuntu.com/USN-4640-1

CVSS

Attack Vector
LOCAL
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-362

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card