CVE-2020-15704

pppd arbitrary file read information disclosure vulnerability

MEDIUM
5.5
CVSS Score
Published: August 31, 2020 at 11:15 PM UTC
Updated: June 17, 2026 at 02:57 AM UTC
2 products affected across 1 vendorPppUbuntu Linux

Using ppp by Canonical?

Get instant alerts when new vulnerabilities affect ppp - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.4%

Description

The modprobe child process in the ./debian/patches/load_ppp_generic_if_needed patch file incorrectly handled module loading. A local non-root attacker could exploit the MODPROBE_OPTIONS environment variable to read arbitrary root files. Fixed in 2.4.5-5ubuntu1.4, 2.4.5-5.1ubuntu2.3+esm2, 2.4.7-1+2ubuntu1.16.04.3, 2.4.7-2+2ubuntu1.3, 2.4.7-2+4.1ubuntu5.1, 2.4.7-2+4.1ubuntu6. Was ZDI-CAN-11504.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.4.5-5.1ubuntu2.3+esm2v < 2.4.5-5ubuntu1.4v < 2.4.7-1+ubuntu1.16.04.3v < 2.4.7-2+2ubuntu1.3v < 2.4.7-2+4.1ubuntu5.12.4.5 ≤ v < 2.4.5-5ubuntu1.42.4.7 ≤ v < 2.4.7-1+2ubuntu1.16.04.32.4.52.4.7
Affected range stops below 2.4.5-5.1ubuntu2.3+esm2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.4.5-5ubuntu1.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.4.7-1+2ubuntu1.16.04.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.4.7-1+ubuntu1.16.04.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.4.7-2+2ubuntu1.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.4.7-2+4.1ubuntu5.1, so it looks safe — our inference, not a vendor statement
canonical-ubuntu-linux (environment)
80%
All versions

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

CVSS

5.5MEDIUMcanonical
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card