CVE-2020-15701

Unhandled exception in apport

MEDIUM
5.5
CVSS Score
Published: August 6, 2020 at 10:50 PM UTC
Updated: June 17, 2026 at 02:57 AM UTC
2 products affected across 2 vendorsUbuntu LinuxApport

Using apport by Canonical?

Get instant alerts when new vulnerabilities affect apport - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.5
Exploit prediction
EPSS 0.4%

Description

An unhandled exception in check_ignored() in apport/report.py can be exploited by a local attacker to cause a denial of service. If the mtime attribute is a string value in apport-ignore.xml, it will trigger an unhandled exception, resulting in a crash. Fixed in 2.20.1-0ubuntu2.24, 2.20.9-0ubuntu7.16, 2.20.11-0ubuntu27.6.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.20.1 ≤ v < 2.20.1-0ubuntu2.242.20.11 ≤ v < 2.20.11-0ubuntu27.62.20.9 ≤ v < 2.20.9-0ubuntu7.162.19.1-0ubuntu32.19.2-0ubuntu12.19.2-0ubuntu22.19.2-0ubuntu32.19.2-0ubuntu42.19.2-0ubuntu52.19.2-0ubuntu62.19.2-0ubuntu72.19.2-0ubuntu82.19.2-0ubuntu92.19.3-0ubuntu12.19.3-0ubuntu22.19.3-0ubuntu32.19.4-0ubuntu12.19.4-0ubuntu22.20-0ubuntu12.20-0ubuntu22.20-0ubuntu32.20.12.20.1-0ubuntu12.20.1-0ubuntu22.20.1-0ubuntu2.12.20.1-0ubuntu2.102.20.1-0ubuntu2.122.20.1-0ubuntu2.132.20.1-0ubuntu2.142.20.1-0ubuntu2.152.20.1-0ubuntu2.162.20.1-0ubuntu2.172.20.1-0ubuntu2.182.20.1-0ubuntu2.192.20.1-0ubuntu2.22.20.1-0ubuntu2.202.20.1-0ubuntu2.212.20.1-0ubuntu2.222.20.1-0ubuntu2.232.20.1-0ubuntu2.42.20.1-0ubuntu2.52.20.1-0ubuntu2.62.20.1-0ubuntu2.72.20.1-0ubuntu2.82.20.1-0ubuntu2.92.20.112.20.11-0ubuntu102.20.11-0ubuntu112.20.11-0ubuntu122.20.11-0ubuntu132.20.11-0ubuntu142.20.11-0ubuntu152.20.11-0ubuntu162.20.11-0ubuntu172.20.11-0ubuntu182.20.11-0ubuntu192.20.11-0ubuntu202.20.11-0ubuntu212.20.11-0ubuntu222.20.11-0ubuntu232.20.11-0ubuntu242.20.11-0ubuntu252.20.11-0ubuntu262.20.11-0ubuntu272.20.11-0ubuntu27.22.20.11-0ubuntu27.32.20.11-0ubuntu27.42.20.11-0ubuntu27.52.20.11-0ubuntu82.20.11-0ubuntu92.20.7-0ubuntu32.20.7-0ubuntu3.12.20.7-0ubuntu42.20.8-0ubuntu12.20.8-0ubuntu102.20.8-0ubuntu22.20.8-0ubuntu32.20.8-0ubuntu42.20.8-0ubuntu52.20.8-0ubuntu62.20.8-0ubuntu72.20.8-0ubuntu82.20.8-0ubuntu92.20.92.20.9-0ubuntu12.20.9-0ubuntu22.20.9-0ubuntu32.20.9-0ubuntu42.20.9-0ubuntu52.20.9-0ubuntu62.20.9-0ubuntu72.20.9-0ubuntu7.12.20.9-0ubuntu7.102.20.9-0ubuntu7.112.20.9-0ubuntu7.122.20.9-0ubuntu7.132.20.9-0ubuntu7.142.20.9-0ubuntu7.152.20.9-0ubuntu7.22.20.9-0ubuntu7.32.20.9-0ubuntu7.42.20.9-0ubuntu7.52.20.9-0ubuntu7.62.20.9-0ubuntu7.72.20.9-0ubuntu7.82.20.9-0ubuntu7.9
Affected range stops below 2.20.1-0ubuntu2.24, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.20.11-0ubuntu27.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.20.9-0ubuntu7.16, so it looks safe — our inference, not a vendor statement
canonical-ubuntu-linux (environment)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (4)

x_refsource_CONFIRMExploitIssue TrackingThird Party Advisory
https://launchpad.net/bugs/1877023
x_refsource_CONFIRMVendor Advisory
https://usn.ubuntu.com/4449-1
Vendor Advisoryx_refsource_UBUNTU
https://usn.ubuntu.com/4449-1/
Vendor Advisoryx_refsource_UBUNTU
https://usn.ubuntu.com/4449-2/

CVSS

5.5MEDIUMcanonical
Attack Vector
LOCAL
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-755

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card