CVE-2020-15269

Expired token reuse in Spree

CRITICAL
9.1
CVSS Score
Published: October 20, 2020 at 08:15 PM UTC
Updated: June 17, 2026 at 02:56 AM UTC
2 products affected across 2 vendorsSpreeSpree

Using spree by spree?

Get instant alerts when new vulnerabilities affect spree - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.1
Exploit prediction
EPSS 1%

Description

In Spree before versions 3.7.11, 4.0.4, or 4.1.11, expired user tokens could be used to access Storefront API v2 endpoints. The issue is patched in versions 3.7.11, 4.0.4 and 4.1.11. A workaround without upgrading is described in the linked advisory.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.7.114.0.0 ≤ v < 4.0.44.1.0 ≤ v < 4.1.11
Affected range stops below 3.7.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.11, so it looks safe — our inference, not a vendor statement
v < 3.7.11v < 4.0.4v < 4.1.11
Affected range stops below 3.7.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.11, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-287CWE-613

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card