CVE-2020-15244

RCE in Magento

HIGH
7.2
CVSS Score
Published: October 21, 2020 at 08:05 PM UTC
Updated: June 17, 2026 at 02:56 AM UTC
1 product affected across 1 vendorMagento

Using magento-lts by OpenMage?

Get instant alerts when new vulnerabilities affect magento-lts - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.2
Exploit prediction
EPSS 1%

Description

In Magento (rubygems openmage/magento-lts package) before versions 19.4.8 and 20.0.4, an admin user can generate soap credentials that can be used to trigger RCE via PHP Object Injection through product attributes and a product. The issue is patched in versions 19.4.8 and 20.0.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 19.4.8v < 19.4.8v < 20.0.420.0.0 ≤ v < 20.0.4
Affected range stops below 19.4.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 20.0.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-74CWE-502

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card