CVE-2020-15240

Regression in JWT Signature Validation

CRITICAL
9.1
CVSS Score
Published: October 21, 2020 at 05:25 PM UTC
Updated: June 17, 2026 at 02:56 AM UTC
1 product affected across 1 vendorOmniauth AUTH0

Using omniauth-auth0 by auth0?

Get instant alerts when new vulnerabilities affect omniauth-auth0 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.1
Exploit prediction
EPSS 0.8%

Description

omniauth-auth0 (rubygems) versions >= 2.3.0 and < 2.4.1 improperly validate the JWT token signature when using the `jwt_validator.verify` method. Improper validation of the JWT token signature can allow an attacker to bypass authentication and authorization. You are affected by this vulnerability if all of the following conditions apply: 1. You are using `omniauth-auth0`. 2. You are using `JWTValidator.verify` method directly OR you are not authenticating using the SDK’s default Authorization Code Flow. The issue is patched in version 2.4.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.4.12.3.0 ≤ v < 2.4.1
Affected range stops below 2.4.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-287CWE-347

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card