CVE-2020-15210

Segmentation fault in tensorflow-lite

MEDIUM
6.5
CVSS Score
Published: September 25, 2020 at 06:45 PM UTC
Updated: June 17, 2026 at 02:56 AM UTC
3 products affected across 3 vendorsLeapTensorflowTensorFlow

Using tensorflow by tensorflow?

Get instant alerts when new vulnerabilities affect tensorflow - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.5
Exploit prediction
EPSS 0.7%

Description

In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.15.42.0.0 ≤ v < 2.0.32.1.0 ≤ v < 2.1.22.2.0 ≤ v < 2.2.12.3.0 ≤ v < 2.3.1
Affected range stops below 1.15.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.3.1, so it looks safe — our inference, not a vendor statement
v < 1.15.4v < 2.0.3v < 2.1.2v < 2.2.1v < 2.3.1
Affected range stops below 1.15.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.0.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.1.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.2.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.3.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

6.5MEDIUMGitHub_M
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
LOW
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-20CWE-787

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card