CVE-2020-15187

Duplicate plugin entries in Helm

MEDIUM
4.7
CVSS Score
Published: September 17, 2020 at 09:50 PM UTC
Updated: June 17, 2026 at 02:56 AM UTC
1 product affected across 1 vendorHelm

Using helm by helm?

Get instant alerts when new vulnerabilities affect helm - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.7
Exploit prediction
EPSS 2%

Description

In Helm before versions 2.16.11 and 3.3.2, a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack. To perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection). This issue has been patched in Helm 2.16.11 and Helm 3.3.2. As a possible workaround make sure to install plugins using a secure connection protocol like SSL.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.16.11v < 3.3.22.0.0 ≤ v < 2.16.113.0.0 ≤ v < 3.3.2
Affected range stops below 2.16.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.3.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-74CWE-694NVD-CWE-Other

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card