CVE-2020-15158

Heap buffer overflow in libIEC61850

CRITICAL
9.8
CVSS Score
Published: August 26, 2020 at 06:00 PM UTC
Updated: June 17, 2026 at 02:56 AM UTC
2 products affected across 1 vendorLIBIEC61850Automation LIBIEC61850

Using libiec61850 by mz-automation?

Get instant alerts when new vulnerabilities affect libiec61850 - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 2%

Description

In libIEC61850 before version 1.4.3, when a message with COTP message length field with value < 4 is received an integer underflow will happen leading to heap buffer overflow. This can cause an application crash or on some platforms even the execution of remote code. If your application is used in open networks or there are untrusted nodes in the network it is highly recommend to apply the patch. This was patched with commit 033ab5b. Users of version 1.4.x should upgrade to version 1.4.3 when available. As a workaround changes of commit 033ab5b can be applied to older versions.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.4.31.4.0 ≤ v < 1.4.3
Affected range stops below 1.4.3, so it looks safe — our inference, not a vendor statement
v < 1.4.31.4.0 ≤ v < 1.4.3
Affected range stops below 1.4.3, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-119CWE-122CWE-191

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card