CVE-2020-15152

Server-Side Request Forgery in ftp-srv

CRITICAL
9.1
CVSS Score
Published: August 17, 2020 at 09:55 PM UTC
Updated: June 17, 2026 at 02:56 AM UTC
2 products affected across 2 vendorsFTP SrvSrv Project FTP Srv

Using ftp-srv by autovance?

Get instant alerts when new vulnerabilities affect ftp-srv - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.1
Exploit prediction
EPSS 2%

Description

ftp-srv is an npm package which is a modern and extensible FTP server designed to be simple yet configurable. In ftp-srv before versions 2.19.6, 3.1.2, and 4.3.4 are vulnerable to Server-Side Request Forgery. The PORT command allows arbitrary IPs which can be used to cause the server to make a connection elsewhere. A possible workaround is blocking the PORT through the configuration. This issue is fixed in version2 2.19.6, 3.1.2, and 4.3.4. More information can be found on the linked advisory.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.19.63.0.0 ≤ v < 3.1.24.0.0 ≤ v < 4.3.4
Affected range stops below 2.19.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.4, so it looks safe — our inference, not a vendor statement
v < 2.19.6v < 3.1.2v < 4.3.4
Affected range stops below 2.19.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.1.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.4, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

CVSS

9.1CRITICALGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card