CVE-2020-11988

HIGH
8.2
CVSS Score
Published: February 24, 2021 at 05:05 PM UTC
Updated: June 17, 2026 at 02:51 AM UTC
2 products affected across 2 vendorsFedoraXmlgraphics Commons

Using Apache XmlGraphics Commons by N/A?

Get instant alerts when new vulnerabilities affect Apache XmlGraphics Commons - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.2
Exploit prediction
EPSS 7%

Description

Apache XmlGraphics Commons 2.4 and earlier is vulnerable to server-side request forgery, caused by improper input validation by the XMPParser. By using a specially-crafted argument, an attacker could exploit this vulnerability to cause the underlying server to make arbitrary GET requests. Users should upgrade to 2.6 or later.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 2.4Apache XmlGraphics Commons ≤ v < 2.6
Affected range stops below 2.6, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-20CWE-918

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card