CVE-2020-11076

HTTP Smuggling via Transfer-Encoding Header in Puma

HIGH
7.5
CVSS Score
Published: May 22, 2020 at 02:50 PM UTC
Updated: June 17, 2026 at 02:48 AM UTC
3 products affected across 3 vendorsDebian LinuxFedoraPuma

Using puma by puma?

Get instant alerts when new vulnerabilities affect puma - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.5
Exploit prediction
EPSS 4%

Description

In Puma (RubyGem) before 4.3.4 and 3.12.5, an attacker could smuggle an HTTP response, by using an invalid transfer-encoding header. The problem has been fixed in Puma 3.12.5 and Puma 4.3.4.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Puma· Pumarubygems
95%
v < 3.12.5v < 4.3.43.0.0 ≤ v < 3.12.64.0.0 ≤ v < 4.3.5
Affected range stops below 3.12.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.12.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.5, so it looks safe — our inference, not a vendor statement

CVSS

7.5HIGHGitHub_M
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
HIGH
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-444

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card