CVE-2020-11041

Improper Validation of Array Index in FreeRDP

LOW
2.7
CVSS Score
Published: May 29, 2020 at 12:00 AM UTC
Updated: June 17, 2026 at 02:48 AM UTC
3 products affected across 3 vendorsDebian LinuxLeapFreeRDP

Using FreeRDP by FreeRDP?

Get instant alerts when new vulnerabilities affect FreeRDP - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
LOW2.7
Exploit prediction
EPSS 1%

Description

In FreeRDP less than or equal to 2.0.0, an outside controlled array index is used unchecked for data used as configuration for sound backend (alsa, oss, pulse, ...). The most likely outcome is a crash of the client instance followed by no or distorted sound or a session disconnect. If a user cannot upgrade to the patched version, a workaround is to disable sound for the session. This has been patched in 2.1.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.1.0<= 2.0.0
Affected range stops below 2.1.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-129

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card