CVE-2020-11026

Specially crafted filenames in WordPress leading to XSS

MEDIUM
5.4
CVSS Score
Published: April 30, 2020 at 10:15 PM UTC
Updated: June 17, 2026 at 02:48 AM UTC
2 products affected across 2 vendorsDebian LinuxWordPress

Using WordPress by WordPress?

Get instant alerts when new vulnerabilities affect WordPress - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 2%

Description

In affected versions of WordPress, files with a specially crafted name when uploaded to the Media section can lead to script execution upon accessing the file. This requires an authenticated user with privileges to upload files. This has been patched in version 5.4.1, along with all the previously affected versions via a minor release (5.3.3, 5.2.6, 5.1.5, 5.0.9, 4.9.14, 4.8.13, 4.7.17, 4.6.18, 4.5.21, 4.4.22, 4.3.23, 4.2.27, 4.1.30, 4.0.30, 3.9.31, 3.8.33, 3.7.33).

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.7.33v < 3.8.33v < 3.9.31v < 4.0.30v < 4.1.30v < 4.2.27v < 4.3.23v < 4.4.22v < 4.5.21v < 4.6.18v < 4.7.17v < 4.8.13v < 4.9.14v < 5.0.9v < 5.1.5v < 5.2.6v < 5.3.3v < 5.4.13.7 ≤ v < 3.7.333.8 ≤ v < 3.8.333.9 ≤ v < 3.9.314.0 ≤ v < 4.0.304.1 ≤ v < 4.1.304.2 ≤ v < 4.2.274.3 ≤ v < 4.3.234.4 ≤ v < 4.4.224.5 ≤ v < 4.5.214.6 ≤ v < 4.6.184.7 ≤ v < 4.7.174.8 ≤ v < 4.8.134.9 ≤ v < 4.9.145.0 ≤ v < 5.0.95.1 ≤ v < 5.1.55.2 ≤ v < 5.2.65.3 ≤ v < 5.3.35.4
Affected range stops below 3.7.33, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.8.33, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.9.31, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.0.30, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.30, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.27, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.23, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.4.22, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.5.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.6.18, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.7.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.8.13, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.9.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.0.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.1.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.3.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.4.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-707CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card