CVE-2020-11023

Potential XSS vulnerability in jQuery

MEDIUM
6.1
CVSS Score
Published: April 29, 2020 at 12:00 AM UTC
Updated: June 17, 2026 at 02:48 AM UTC
60 products affected across 7 vendorsDebian LinuxFedoraOnCommand Insight

Using jQuery by jquery?

Get instant alerts when new vulnerabilities affect jQuery - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploitation
CISA KEV
Exploit prediction
EPSS 85%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score84.9%

EPSS (Exploit Prediction Scoring System) estimates a 84.9% chance this CVE is exploited in the wild within the next 30 days — higher than 100% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

JQuery contains a persistent cross-site scripting (XSS) vulnerability. When passing maliciously formed, untrusted input enclosed in HTML tags, JQuery's DOM manipulators can execute untrusted code in the context of the user's browser.

Required Action
Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.
Ransomware Use
Unknown
Added to KEV
Jan 23, 2025
Remediation Due
Feb 13, 2025
620 days overdue

Description

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

7.0 ≤ v < 7.708.7.0 ≤ v < 8.7.148.8.0 ≤ v < 8.8.6
Affected range stops below 7.70, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.7.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.8.6, so it looks safe — our inference, not a vendor statement
v < 3.5.01.0.3 ≤ v < 3.5.0
Affected range stops below 3.5.0, so it looks safe — our inference, not a vendor statement
All versions
All versions
netapp-h300e (same device)
All versions
netapp-h300s (same device)
All versions
netapp-h410c (same device)

SSVC — Action Prioritization

SSVCActiveNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusANALYZED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card