CVE-2020-11022

jQuery has a potential XSS vulnerability

MEDIUM
6.1
CVSS Score
Published: April 29, 2020 at 12:00 AM UTC
Updated: June 17, 2026 at 02:48 AM UTC
78 products affected across 8 vendorsDebian LinuxFedoraLeap

Using jQuery by jquery?

Get instant alerts when new vulnerabilities affect jQuery - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.1
Exploit prediction
EPSS 99%

Description

In jQuery versions greater than or equal to 1.2 and before 3.5.0, passing HTML from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

7.0 ≤ v < 7.708.7.0 ≤ v < 8.7.148.8.0 ≤ v < 8.8.6
Affected range stops below 7.70, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.7.14, so it looks safe — our inference, not a vendor statement
Affected range stops below 8.8.6, so it looks safe — our inference, not a vendor statement
v < 3.5.01.2 ≤ v < 3.5.0
Affected range stops below 3.5.0, so it looks safe — our inference, not a vendor statement
All versions
netapp-h300e (same device)
All versions
netapp-h300s (same device)
All versions
netapp-h410c (same device)
All versions
netapp-h410s (same device)
All versions
netapp-h500e (same device)
All versions
netapp-h500s (same device)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card