CVE-2020-10518

Unsafe configuration options in GitHub Pages leading to remote code execution on GitHub Enterprise Server

HIGH
8.8
CVSS Score
Published: August 27, 2020 at 09:55 PM UTC
Updated: June 17, 2026 at 02:47 AM UTC
2 products affected across 1 vendorGitHubGitHub Enterprise Server

Using GitHub Enterprise Server by GitHub?

Get instant alerts when new vulnerabilities affect GitHub Enterprise Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.8
Exploit prediction
EPSS 4%

Description

A remote code execution vulnerability was identified in GitHub Enterprise Server that could be exploited when building a GitHub Pages site. User-controlled configuration of the underlying parsers used by GitHub Pages were not sufficiently restricted and made it possible to execute commands on the GitHub Enterprise Server instance. To exploit this vulnerability, an attacker would need permission to create and build a GitHub Pages site on the GitHub Enterprise Server instance. This vulnerability affected all versions of GitHub Enterprise Server prior to 2.22 and was fixed in 2.21.6, 2.20.15, and 2.19.21. The underlying issues contributing to this vulnerability were identified both internally and through the GitHub Security Bug Bounty program.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.19.212.20.0 ≤ v < 2.20.152.21.0 ≤ v < 2.21.6
Affected range stops below 2.19.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.20.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.21.6, so it looks safe — our inference, not a vendor statement
2.19 ≤ v < 2.19.212.20 ≤ v < 2.20.152.21 ≤ v < 2.21.62.192.202.21
Affected range stops below 2.19.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.20.15, so it looks safe — our inference, not a vendor statement
Affected range stops below 2.21.6, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_MISCRelease NotesVendor Advisory
https://enterprise.github.com/releases/2.19.21/notes
x_refsource_MISCRelease NotesVendor Advisory
https://enterprise.github.com/releases/2.20.15/notes
x_refsource_MISCRelease NotesVendor Advisory
https://enterprise.github.com/releases/2.21.6/notes

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-77NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card