CVE-2020-10018

CRITICAL
9.8
CVSS Score
Published: March 2, 2020 at 10:11 PM UTC
Updated: June 17, 2026 at 02:47 AM UTC
6 products affected across 6 vendorsDebian LinuxFedoraUbuntu Linux

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 5%

Description

WebKitGTK through 2.26.4 and WPE WebKit through 2.26.4 (which are the versions right before 2.28.0) contains a memory corruption issue (use-after-free) that may lead to arbitrary code execution. This issue has been fixed in 2.28.0 with improved memory handling.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.28.0
Affected range stops below 2.28.0, so it looks safe — our inference, not a vendor statement
v < 2.28.0
Affected range stops below 2.28.0, so it looks safe — our inference, not a vendor statement

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-416

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card