CVE-2019-9636

CRITICAL
9.8
CVSS Score
Published: March 8, 2019 at 09:00 PM UTC
Updated: October 14, 2026 at 07:16 AM UTC
16 products affected across 7 vendorsDebian LinuxFedoraUbuntu Linux· also runs on 1 platform

Using N/A by N/A?

Get instant alerts when new vulnerabilities affect N/A - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 8%
SSVC
No known exploit

Description

Python 2.7.x through 2.7.16 and 3.x through 3.7.2 is affected by: Improper Handling of Unicode Encoding (with an incorrect netloc) during NFKC normalization. The impact is: Information disclosure (credentials, cookies, etc. that are cached against a given hostname). The components are: urllib.parse.urlsplit, urllib.parse.urlparse. The attack vector is: A specially crafted URL could be incorrectly parsed to locate cookies or authentication data and send that information to a different host than when parsed correctly. This is fixed in: v2.7.17, v2.7.17rc1, v2.7.18, v2.7.18rc1; v3.5.10, v3.5.10rc1, v3.5.7, v3.5.8, v3.5.8rc1, v3.5.8rc2, v3.5.9; v3.6.10, v3.6.10rc1, v3.6.11, v3.6.11rc1, v3.6.12, v3.6.9, v3.6.9rc1; v3.7.3, v3.7.3rc1, v3.7.4, v3.7.4rc1, v3.7.4rc2, v3.7.5, v3.7.5rc1, v3.7.6, v3.7.6rc1, v3.7.7, v3.7.7rc1, v3.7.8, v3.7.8rc1, v3.7.9.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

2.7.0 ≤ v < 2.7.173.0.0 ≤ v < 3.4.103.5.0 ≤ v < 3.5.73.6.0 ≤ v < 3.6.93.7.0 ≤ v < 3.7.3
Affected range stops below 2.7.17, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.4.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.5.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.6.9, so it looks safe — our inference, not a vendor statement
Affected range stops below 3.7.3, so it looks safe — our inference, not a vendor statement

Runs on — not affected

The affected product only carries this flaw when running on these platforms. The platforms themselves are not vulnerable.

References (53)

Vendor Advisoryx_refsource_SUSEMailing ListThird Party Advisory
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00092.html
Vendor Advisoryx_refsource_SUSEMailing ListThird Party Advisory
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00097.html
Vendor Advisoryx_refsource_SUSEMailing ListThird Party Advisory
http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00024.html
Vendor Advisoryx_refsource_SUSEMailing ListThird Party Advisory
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00050.html
Vendor Advisoryx_refsource_SUSEMailing ListThird Party Advisory
http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00042.html
Vendor Advisoryx_refsource_SUSEMailing ListThird Party Advisory
http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00040.html
VDB Entryx_refsource_BIDThird Party Advisory
http://www.securityfocus.com/bid/107400
Vendor Advisoryx_refsource_REDHATThird Party Advisory
https://access.redhat.com/errata/RHBA-2019:0763

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-noinfoCWE-173

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card