CVE-2019-5448

HIGH
8.1
CVSS Score
Published: July 30, 2019 at 08:15 PM UTC
Updated: June 17, 2026 at 02:37 AM UTC
2 products affected across 2 vendorsYarnYarn

Using yarn by yarn?

Get instant alerts when new vulnerabilities affect yarn - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH8.1
Exploit prediction
EPSS 0.7%

Description

Yarn before 1.17.3 is vulnerable to Missing Encryption of Sensitive Data due to HTTP URLs in lockfile causing unencrypted authentication data to be sent over the network.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.17.3
Affected range stops below 1.17.3, so it looks safe — our inference, not a vendor statement
All versions
Vendor states this is fixed in 1.17.3 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (3)

x_refsource_MISCExploitThird Party Advisory
https://github.com/ChALkeR/notes/blob/master/Yarn-vuln.md
x_refsource_MISCPermissions RequiredThird Party Advisory
https://hackerone.com/reports/640904

CVSS

Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-311CWE-319

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card