CVE-2019-3829

MEDIUM
5.3
CVSS Score
Published: March 27, 2019 at 05:24 PM UTC
Updated: June 17, 2026 at 02:35 AM UTC
3 products affected across 3 vendorsFedoraGnutlsGnuTLS

Using gnutls by gnutls?

Get instant alerts when new vulnerabilities affect gnutls - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.3
Exploit prediction
EPSS 59%

Description

A vulnerability was found in gnutls versions from 3.5.8 before 3.6.7. A memory corruption (double free) vulnerability in the certificate verification API. Any client or server application that verifies X.509 certificates with GnuTLS 3.5.8 or later is affected.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

All versions
3.5.8 ≤ v < 3.6.7
Affected range stops below 3.6.7, so it looks safe — our inference, not a vendor statement
v ≥ 3.5.8
Vendor states this is fixed in 3.6.7 (unaffected)

CVSS

5.3MEDIUMredhat
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-416CWE-415

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card