CVE-2019-3602

Cross site scripting vulnerability in McAfee NSM impacting authenticated users

MEDIUM
4.8
CVSS Score
Published: May 15, 2019 at 03:47 PM UTC
Updated: June 17, 2026 at 02:35 AM UTC
1 product affected across 1 vendorNetwork Security Manager

Using McAfee Network Security Manager (NSM) by McAfee, LLC?

Get instant alerts when new vulnerabilities affect McAfee Network Security Manager (NSM) - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.8
Exploit prediction
EPSS 0.6%

Description

Cross Site Scripting (XSS) vulnerability in McAfee Network Security Manager (NSM) Prior to 9.1 Update 5 allows an authenticated administrator to embed an XSS in the administrator interface via a specially crafted custom rule containing HTML.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 9.19.1 ≤ v < 9.1 update 5 (9.1.7.77)9.19.1 update_19.1 update_29.1 update_39.1 update_4
Affected range stops below 9.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 9.1 update 5 (9.1.7.77), so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet, and no fixed version or vendor advisory is recorded against it.

CVSS

4.8MEDIUMtrellix
Attack Vector
NETWORK
Complexity
LOW
Privileges
HIGH
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card