CVE-2019-3396

CRITICAL
9.8
CVSS Score
Published: March 25, 2019 at 06:37 PM UTC
Updated: June 17, 2026 at 02:35 AM UTC
1 product affected across 1 vendorConfluence Server

Using Confluence Server by Atlassian?

Get instant alerts when new vulnerabilities affect Confluence Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploitation
CISA KEV
Exploit prediction
EPSS 100%
SSVC
Active

Actively Exploited

CISA Known Exploited Vulnerabilities (KEV) Catalog

EPSS Score99.9%

EPSS (Exploit Prediction Scoring System) estimates a 99.9% chance this CVE is exploited in the wild within the next 30 days — higher than 100% of all CVEs. It complements CVSS: a high EPSS on a mid-severity CVE can still be urgent.

Atlassian Confluence Server and Data Center contain a server-side template injection vulnerability that may allow an attacker to achieve path traversal and remote code execution.

Required Action
Apply updates per vendor instructions.
Ransomware Use
Known
Added to KEV
Nov 3, 2021
Remediation Due
May 3, 2022
1639 days overdue

Description

The Widget Connector macro in Atlassian Confluence Server before version 6.6.12 (the fixed version for 6.6.x), from version 6.7.0 before 6.12.3 (the fixed version for 6.12.x), from version 6.13.0 before 6.13.3 (the fixed version for 6.13.x), and from version 6.14.0 before 6.14.2 (the fixed version for 6.14.x), allows remote attackers to achieve path traversal and remote code execution on a Confluence Server or Data Center instance via server-side template injection.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≥ 6.7.0v ≥ next of 6.13.0v ≥ next of 6.14.0v < 6.12.3v < 6.13.3v < 6.14.2v < 6.6.126.13.0 ≤ v < 6.13.36.14.0 ≤ v < 6.14.26.7.0 ≤ v < 6.12.36.7.0next of 6.13.0next of 6.14.0
Affected range stops below 6.12.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.13.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.14.2, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.6.12, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (6)

SSVC — Action Prioritization

SSVCActiveAutomatableTotal impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

9.8CRITICALCISA-ADP
Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusANALYZED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card