CVE-2019-19348

HIGH
7
CVSS Score
Published: April 2, 2020 at 07:14 PM UTC
Updated: June 17, 2026 at 02:26 AM UTC
2 products affected across 2 vendorsOpenshiftOpenShift

Using openshift/apb-base by Openshift Enterprise?

Get instant alerts when new vulnerabilities affect openshift/apb-base - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7
Exploit prediction
EPSS 0.3%

Description

An insecure modification vulnerability in the /etc/passwd file was found in the container openshift/apb-base, affecting versions before the following 4.3.5, 4.2.21, 4.1.37, and 3.11.188-4. An attacker with access to the container could use this flaw to modify /etc/passwd and escalate their privileges.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 3.11.188-44.0.0 ≤ v < 4.1.374.2.0 ≤ v < 4.2.214.3.0 ≤ v < 4.3.5
Affected range stops below 3.11.188-4, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.1.37, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.2.21, so it looks safe — our inference, not a vendor statement
Affected range stops below 4.3.5, so it looks safe — our inference, not a vendor statement
All versions
Vendor states this is fixed in 3.11.188-4 (unaffected)
Vendor states this is fixed in 4.1.37-202003021622 (unaffected)
Vendor states this is fixed in 4.2.21-202002240343 (unaffected)
Vendor states this is fixed in 4.3.5-202003020549 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

x_refsource_CONFIRMIssue TrackingVendor Advisory
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-19348

CVSS

7HIGHredhat
Attack Vector
LOCAL
Complexity
HIGH
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-266CWE-269

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card