CVE-2019-16780

Stored cross-site scripting (XSS) in WordPress block editor

MEDIUM
5.4
CVSS Score
Published: December 26, 2019 at 04:50 PM UTC
Updated: June 17, 2026 at 02:22 AM UTC
2 products affected across 2 vendorsDebian LinuxWordPress

Using WordPress by WordPress?

Get instant alerts when new vulnerabilities affect WordPress - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 2%

Description

WordPress users with lower privileges (like contributors) can inject JavaScript code in the block editor using a specific payload, which is executed within the dashboard. This can lead to XSS if an admin opens the post in the editor. Execution of this attack does require an authenticated user. This has been patched in WordPress 5.3.1, along with all the previous WordPress versions from 3.7 to 5.3 via a minor release. Automatic updates are enabled by default for minor releases and we strongly recommend that you keep them enabled.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

< 5.3.1 ≤ v < 5.3.13.7 < v < 5.3.13.7< 5.3.1
Affected range stops below 5.3.1, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (8)

x_refsource_MISCPermissions RequiredThird Party Advisory
https://hackerone.com/reports/738644
Mailing Listx_refsource_BUGTRAQThird Party Advisory
https://seclists.org/bugtraq/2020/Jan/8
x_refsource_MISCThird Party Advisory
https://wpvulndb.com/vulnerabilities/9976
Vendor Advisoryx_refsource_DEBIANThird Party Advisory
https://www.debian.org/security/2020/dsa-4599
Vendor Advisoryx_refsource_DEBIANThird Party Advisory
https://www.debian.org/security/2020/dsa-4677

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-79

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card