CVE-2019-15795

python-apt uses MD5 for validation

MEDIUM
4.7
CVSS Score
Published: March 26, 2020 at 01:00 PM UTC
Updated: June 17, 2026 at 02:21 AM UTC
3 products affected across 3 vendorsPython AptPython AptUbuntu Linux

Using Python-apt by Canonical?

Get instant alerts when new vulnerabilities affect Python-apt - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.7
Exploit prediction
EPSS 0.5%

Description

python-apt only checks the MD5 sums of downloaded files in `Version.fetch_binary()` and `Version.fetch_source()` of apt/package.py in version 1.9.0ubuntu1 and earlier. This allows a man-in-the-middle attack which could potentially be used to install altered packages and has been fixed in versions 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, and 0.8.3ubuntu7.5.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

canonical-ubuntu-linux (environment)
Affected range stops below 0.8.3ubuntu7.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 0.9.3.5ubuntu3+esm2, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.1.0~beta1ubuntu0.16.04.7, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.6.5ubuntu0.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 1.9.0ubuntu1.2, so it looks safe — our inference, not a vendor statement
canonical-ubuntu-linux (environment)
80%
All versions

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (2)

Vendor Advisoryx_refsource_UBUNTUPatch
https://usn.ubuntu.com/4247-1/
Vendor Advisoryx_refsource_UBUNTUPatch
https://usn.ubuntu.com/4247-3/

CVSS

4.7MEDIUMcanonical
Attack Vector
NETWORK
Complexity
HIGH
Privileges
NONE
User Interaction
REQUIRED
Scope
CHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-327

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card