CVE-2019-15000

CRITICAL
9.8
CVSS Score
Published: September 19, 2019 at 02:24 PM UTC
Updated: June 17, 2026 at 02:19 AM UTC
3 products affected across 1 vendorBitbucketBitbucket ServerBitbucket Data Center

Using Bitbucket Server by Atlassian?

Get instant alerts when new vulnerabilities affect Bitbucket Server - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 8%

Description

The commit diff rest endpoint in Bitbucket Server and Data Center before 5.16.10 (the fixed version for 5.16.x ), from 6.0.0 before 6.0.10 (the fixed version for 6.0.x), from 6.1.0 before 6.1.8 (the fixed version for 6.1.x), from 6.2.0 before 6.2.6 (the fixed version for 6.2.x), from 6.3.0 before 6.3.5 (the fixed version for 6.3.x), from 6.4.0 before 6.4.3 (the fixed version for 6.4.x), and from 6.5.0 before 6.5.2 (the fixed version for 6.5.x) allows remote attackers who have permission to access a repository, if public access is enabled for a project or repository then attackers are able to exploit this issue anonymously, to read the contents of arbitrary files on the system and execute commands via injecting additional arguments into git commands.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

95%
5.16.0 ≤ v < 5.16.106.0.0 ≤ v < 6.0.106.1.0 ≤ v < 6.1.86.2.0 ≤ v < 6.2.66.3.0 ≤ v < 6.3.56.4.0 ≤ v < 6.4.36.5.0 ≤ v < 6.5.2
Affected range stops below 5.16.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.3.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.5.2, so it looks safe — our inference, not a vendor statement
v ≥ 6.0.0v ≥ 6.1.0v ≥ 6.2.0v ≥ 6.3.0v ≥ 6.4.0v ≥ 6.5.0v < 5.16.10v < 6.0.10v < 6.1.8v < 6.2.6v < 6.3.5v < 6.4.3v < 6.5.26.0.06.1.06.2.06.3.06.4.06.5.0
Affected range stops below 5.16.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.3.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.5.2, so it looks safe — our inference, not a vendor statement
v ≥ 6.0.0v ≥ 6.1.0v ≥ 6.2.0v ≥ 6.3.0v ≥ 6.4.0v ≥ 6.5.0v < 5.16.10v < 6.0.10v < 6.1.8v < 6.2.6v < 6.3.5v < 6.4.3v < 6.5.26.0.06.1.06.2.06.3.06.4.06.5.0
Affected range stops below 5.16.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.0.10, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.1.8, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.2.6, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.3.5, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.4.3, so it looks safe — our inference, not a vendor statement
Affected range stops below 6.5.2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-78

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card