CVE-2019-11994

CRITICAL
9.8
CVSS Score
Published: January 3, 2020 at 05:23 PM UTC
Updated: June 17, 2026 at 02:13 AM UTC
17 products affected across 1 vendorSimplivity Omnicube FirmwareSimplivity Omnistack for Dell FirmwareSimplivity Omnistack for Cisco Firmware

Using HPE SimpliVity 2600 Gen10; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; HPE SimpliVity 380 Gen9; SimpliVity OmniCube; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; SimpliVity OmniStack for Lenovo by N/A?

Get instant alerts when new vulnerabilities affect HPE SimpliVity 2600 Gen10; HPE SimpliVity 380 Gen10; HPE SimpliVity 380 Gen10 G; HPE SimpliVity 380 Gen9; SimpliVity OmniCube; SimpliVity OmniStack for Cisco; SimpliVity OmniStack for Dell; SimpliVity OmniStack for Lenovo - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
CRITICAL9.8
Exploit prediction
EPSS 7%

Description

A security vulnerability has been identified in HPE SimpliVity 380 Gen 9, HPE SimpliVity 380 Gen 10, HPE SimpliVity 380 Gen 10 G, HPE SimpliVity 2600 Gen 10, SimpliVity OmniCube, SimpliVity OmniStack for Cisco, SimpliVity OmniStack for Lenovo and SimpliVity OmniStack for Dell nodes. An API is used to execute a command manifest file during upgrade does not correctly prevent directory traversal and so can be used to execute manifest files in arbitrary locations on the node. The API does not require user authentication and is accessible over the management network, resulting in the potential for unauthenticated remote execution of manifest files. For all customers running HPE OmniStack version 3.7.9 and earlier. HPE recommends upgrading the OmniStack software to version 3.7.10 or later, which contains a permanent resolution. Customers and partners who can upgrade to 3.7.10 should upgrade at the earliest convenience. For all customers and partners unable to upgrade their environments to the recommended version 3.7.10, HPE has created a Temporary Workaround https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=mmr_sf-EN_US000061901&withFrame for you to implement. All customer should upgrade to the recommended 3.7.10 or later version at the earliest convenience.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

3.7.5 ≤ v ≤ 3.7.9
hp-simplivity-2600-gen10 (same device)
3.7.1 ≤ v ≤ 3.7.9
hp-simplivity-380-gen10 (same device)
3.7.8 ≤ v ≤ 3.7.9
hp-simplivity-380-gen10-g (same device)
3.6.2 ≤ v ≤ 3.7.9
hp-simplivity-380-gen9 (same device)
3.5.2 ≤ v ≤ 3.7.9
hp-simplivity-omnicube (same device)
3.5.2 ≤ v ≤ 3.7.9
hp-simplivity-omnistack-for-cisco (same device)
3.5.2 ≤ v ≤ 3.7.9
hp-simplivity-omnistack-for-dell (same device)
3.5.2 ≤ v ≤ 3.7.9
hp-simplivity-omnistack-for-lenovo (same device)
3.5.2 ≤ v ≤ 3.7.93.6.2 ≤ v ≤ 3.7.93.7.1 ≤ v ≤ 3.7.93.7.5 ≤ v ≤ 3.7.93.7.8 ≤ v ≤ 3.7.9
3.5.2 ≤ v ≤ 3.7.93.6.2 ≤ v ≤ 3.7.93.7.1 ≤ v ≤ 3.7.93.7.5 ≤ v ≤ 3.7.93.7.8 ≤ v ≤ 3.7.9

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-22

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card