CVE-2019-1020018

HIGH
7.3
CVSS Score
Published: July 29, 2019 at 01:14 PM UTC
Updated: June 17, 2026 at 02:10 AM UTC
1 product affected across 1 vendorDiscourse

Using Discourse by N/A?

Get instant alerts when new vulnerabilities affect Discourse - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
HIGH7.3
Exploit prediction
EPSS 1%

Description

Discourse before 2.3.0 and 2.4.x before 2.4.0.beta3 lacks a confirmation screen when logging in via an email link.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.3.02.4.0 beta12.4.0 beta22.4.0.beta12.4.0.beta2
Affected range stops below 2.3.0, so it looks safe — our inference, not a vendor statement
Vendor states this is fixed in 2.4.0.beta3 (unaffected)

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-287

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card