CVE-2019-10163

MEDIUM
4.3
CVSS Score
Published: July 30, 2019 at 10:16 PM UTC
Updated: June 17, 2026 at 02:10 AM UTC
3 products affected across 2 vendorsLeapBackportsAuthoritative

Using pdns by PowerDNS?

Get instant alerts when new vulnerabilities affect pdns - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 1%

Description

A Vulnerability has been found in PowerDNS Authoritative Server before versions 4.1.9, 4.0.8 allowing a remote, authorized master server to cause a high CPU load or even prevent any further updates to any slave zone by sending a large number of NOTIFY messages. Note that only servers configured as slaves are affected by this issue.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

4.0.0 ≤ v < 4.0.84.1.0 ≤ v < 4.1.94.1.0
Vendor states this is fixed in 4.0.8 (unaffected)
Vendor states this is fixed in 4.1.9 (unaffected)

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
NONE
Integrity
NONE
Availability
LOW
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-770

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card