CVE-2019-10156

MEDIUM
5.4
CVSS Score
Published: July 30, 2019 at 10:12 PM UTC
Updated: June 17, 2026 at 02:10 AM UTC
3 products affected across 2 vendorsDebian LinuxOpenStackAnsible

Using ansible by Red Hat?

Get instant alerts when new vulnerabilities affect ansible - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM5.4
Exploit prediction
EPSS 2%

Description

A flaw was discovered in the way Ansible templating was implemented in versions before 2.6.18, 2.7.12 and 2.8.2, causing the possibility of information disclosure through unexpected variable substitution. By taking advantage of unintended variable substitution the content of any variable may be disclosed.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 2.6.182.7.0 ≤ v < 2.7.122.8.0 ≤ v < 2.8.2
Vendor states this is fixed in 2.6.18 (unaffected)
Vendor states this is fixed in 2.7.12 (unaffected)
Vendor states this is fixed in 2.8.2 (unaffected)

References (7)

x_refsource_CONFIRMIssue TrackingVendor Advisory
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2019-10156
x_refsource_CONFIRMPatchThird Party Advisory
https://github.com/ansible/ansible/pull/57188
Mailing Listx_refsource_MLISTThird Party Advisory
https://lists.debian.org/debian-lts-announce/2021/01/msg00023.html
Vendor Advisoryx_refsource_DEBIANThird Party Advisory
https://www.debian.org/security/2021/dsa-4950

CVSS

Attack Vector
NETWORK
Complexity
LOW
Privileges
LOW
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
LOW
Integrity
LOW
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-200

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card