CVE-2019-0035

Junos OS: 'set system ports console insecure' allows root password recovery on OAM volumes

MEDIUM
6.8
CVSS Score
Published: April 10, 2019 at 08:13 PM UTC
Updated: June 17, 2026 at 02:07 AM UTC
1 product affected across 1 vendorJunos

Using Junos OS by Juniper Networks?

Get instant alerts when new vulnerabilities affect Junos OS - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM6.8
Exploit prediction
EPSS 0.4%

Description

When "set system ports console insecure" is enabled, root login is disallowed for Junos OS as expected. However, the root password can be changed using "set system root-authentication plain-text-password" on systems booted from an OAM (Operations, Administration, and Maintenance) volume, leading to a possible administrative bypass with physical access to the console. OAM volumes (e.g. flash drives) are typically instantiated as /dev/gpt/oam, or /oam for short. Password recovery, changing the root password from a console, should not have been allowed from an insecure console. Affected releases are Juniper Networks Junos OS: 15.1 versions prior to 15.1F6-S12, 15.1R7-S3; 15.1X49 versions prior to 15.1X49-D160; 15.1X53 versions prior to 15.1X53-D236, 15.1X53-D496, 15.1X53-D68; 16.1 versions prior to 16.1R3-S10, 16.1R6-S6, 16.1R7-S3; 16.1X65 versions prior to 16.1X65-D49; 16.2 versions prior to 16.2R2-S8; 17.1 versions prior to 17.1R2-S10, 17.1R3; 17.2 versions prior to 17.2R1-S8, 17.2R3-S1; 17.3 versions prior to 17.3R3-S3; 17.4 versions prior to 17.4R1-S6, 17.4R2-S2; 18.1 versions prior to 18.1R2-S4, 18.1R3-S3; 18.2 versions prior to 18.2R2; 18.2X75 versions prior to 18.2X75-D40; 18.3 versions prior to 18.3R1-S2. This issue does not affect Junos OS releases prior to 15.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Vendor states this is fixed in 15.1 (unaffected)
Affected range stops below 15.1X49-D160, so it looks safe — our inference, not a vendor statement
Affected range stops below 15.1X53-D236, 15.1X53-D496, 15.1X53-D68, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.1R3-S10, 16.1R6-S6, 16.1R7-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.1X65-D49, so it looks safe — our inference, not a vendor statement
Affected range stops below 16.2R2-S8, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.1R2-S10, 17.1R3, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.2R1-S8, 17.2R3-S1, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.3R3-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 17.4R1-S6, 17.4R2-S2, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.1R2-S4, 18.1R3-S3, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.2R2, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.2X75-D40, so it looks safe — our inference, not a vendor statement
Affected range stops below 18.3R1-S2, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

Patch and advisory references

References (1)

x_refsource_CONFIRMVendor Advisory
https://kb.juniper.net/JSA10924

CVSS

Attack Vector
PHYSICAL
Complexity
LOW
Privileges
NONE
User Interaction
NONE
Scope
UNCHANGED
Confidentiality
HIGH
Integrity
HIGH
Availability
HIGH
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-501CWE-522

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card