CVE-2018-8007

N/A
Published: July 11, 2018 at 01:00 PM UTC
Updated: June 17, 2026 at 02:04 AM UTC
1 product affected across 1 vendorCouchdb

Using Apache CouchDB by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache CouchDB - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
N/A
Exploit prediction
EPSS 12%

Description

Apache CouchDB administrative users can configure the database server via HTTP(S). Due to insufficient validation of administrator-supplied configuration settings via the HTTP API, it is possible for a CouchDB administrator user to escalate their privileges to that of the operating system's user that CouchDB runs under, by bypassing the blacklist of configuration settings that are not allowed to be modified via the HTTP API. This privilege escalation effectively allows an existing CouchDB admin user to gain arbitrary remote code execution, bypassing already disclosed CVE-2017-12636. Mitigation: All users should upgrade to CouchDB releases 1.7.2 or 2.1.2.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v ≤ 1.7.1v < 1.7.22.0.0 ≤ v ≤ 2.1.1
Affected range stops below 1.7.2, so it looks safe — our inference, not a vendor statement

CVSS

Confidentiality
COMPLETE
Integrity
COMPLETE
Availability
COMPLETE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-20

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card