CVE-2018-25104

CoinGate Plugin Payment callback.php postProcess logic error

MEDIUM
4.3
CVSS Score
Published: October 17, 2024 at 03:31 PM UTC
Updated: June 17, 2026 at 01:54 AM UTC
1 product affected across 1 vendorCoinGate Plugin

Using CoinGate Plugin by N/A?

Get instant alerts when new vulnerabilities affect CoinGate Plugin - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
MEDIUM4.3
Exploit prediction
EPSS 0.4%
SSVC
No known exploit

Description

A vulnerability was found in CoinGate Plugin up to 1.2.7 on PrestaShop. It has been rated as problematic. Affected by this issue is the function postProcess of the file modules/coingate/controllers/front/callback.php of the component Payment Handler. The manipulation leads to business logic errors. The attack may be launched remotely. Upgrading to version 1.2.8 is able to address this issue. The patch is identified as 0a3097db0aec7c5d66686c142c6abaa1e126ca16. It is recommended to upgrade the affected component.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

SSVC — Action Prioritization

SSVCNo known exploitNot automatablePartial impact

SSVC signals action urgency (what to patch first), separate from CVSS which measures severity.

CVSS

4.3MEDIUMVulDB
Vector?

Quick Info

StatusDEFERRED
CWE
CWE-840

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card