CVE-2018-16476

N/A
Published: November 30, 2018 at 07:00 PM UTC
Updated: June 17, 2026 at 01:44 AM UTC
2 products affected across 2 vendorsRailsCloudForms

Using https://github.com/rails/rails by N/A?

Get instant alerts when new vulnerabilities affect https://github.com/rails/rails - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
N/A
Exploit prediction
EPSS 3%

Description

A Broken Access Control vulnerability in Active Job versions >= 4.2.0 allows an attacker to craft user input which can cause Active Job to deserialize it using GlobalId and give them access to information that they should not have. This vulnerability has been fixed in versions 4.2.11, 5.0.7.1, 5.1.6.1, and 5.2.1.1.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 4.2.11v < 5.0.7.1v < 5.1.6.1v < 5.2.1.14.2.0 ≤ v < 4.2.115.0.0 ≤ v < 5.0.7.15.1.0 ≤ v < 5.1.6.15.2.0 ≤ v < 5.2.1.1
Affected range stops below 4.2.11, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.0.7.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.1.6.1, so it looks safe — our inference, not a vendor statement
Affected range stops below 5.2.1.1, so it looks safe — our inference, not a vendor statement

References (3)

CVSS

Confidentiality
PARTIAL
Integrity
NONE
Availability
NONE
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-284CWE-502

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card