CVE-2018-1335

N/A
Published: April 25, 2018 at 09:00 PM UTC
Updated: June 17, 2026 at 01:51 AM UTC
1 product affected across 1 vendorTika

Using Apache Tika by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache Tika - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
N/A
Exploit prediction
EPSS 94%

Description

From Apache Tika versions 1.7 to 1.17, clients could send carefully crafted headers to tika-server that could be used to inject commands into the command line of the server running tika-server. This vulnerability only affects those running tika-server on a server that is open to untrusted clients. The mitigation is to upgrade to Tika 1.18.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.181.7 ≤ v ≤ 1.17
Affected range stops below 1.18, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

CVSS

Confidentiality
COMPLETE
Integrity
COMPLETE
Availability
COMPLETE
Vector?

Quick Info

StatusMODIFIED
CWE
NVD-CWE-noinfo

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card