CVE-2018-1310

N/A
Published: May 23, 2018 at 02:00 PM UTC
Updated: June 17, 2026 at 01:50 AM UTC
1 product affected across 1 vendorNifi

Using Apache NiFi by Apache Software Foundation?

Get instant alerts when new vulnerabilities affect Apache NiFi - before attackers find them.

Real-time alertsTrack your software stackFree plan available
Severity
N/A
Exploit prediction
EPSS 3%

Description

Apache NiFi JMS Deserialization issue because of ActiveMQ client vulnerability. Malicious JMS content could cause denial of service. See ActiveMQ CVE-2015-5254 announcement for more information. The fix to upgrade the activemq-client library to 5.15.3 was applied on the Apache NiFi 1.6.0 release. Users running a prior 1.x release should upgrade to the appropriate release.

Affected

Our own answer: ranges merged, affected separated from platform-only, with confidence and review flags.

v < 1.6.00.1.0 - 1.5.0
Affected range stops below 1.6.0, so it looks safe — our inference, not a vendor statement

Remediation

No guide yet

No remediation guidance has been written for this CVE yet. What the record does show:

References (1)

CVSS

Confidentiality
NONE
Integrity
NONE
Availability
PARTIAL
Vector?

Quick Info

StatusMODIFIED
CWE
CWE-502

Get alerted

Stop reading CVE feeds looking for your own stack

Track the products you run and VulnTracker tells you when a new CVE affects them — with what is known about fixing it, and nothing about the rest.

Free plan, no card